Sortie de la 5.4

16 November 2019 à 09:15

Nouvelle gestion des mots de passe dans la base de donnée farmserv:

Services blog, rss et statsperso :

Tout les services sont désormais activés pour tout le monde (blog,partage,rss et statsperso). Il n'y a plus besoin de les activer à partir de la console de gestion.

Compatibilité PHP 7.0 :

Migration du code pour passer de mysql à mysqli pour une compatibilité 100% PHP 7.0, abandon de la classe mysql2i et optimisation des requêtes SQL.
Protection contre les injections SQL en sécurisant les variables $_GET dans toutes les pages PHP avec la routine real_escape_string.

Réglages :

Divers :

Plus de détails içi sur cette mise à jour.

TRÉS IMPORTANT :

Après avoir appliqué la mise à la jour automatique, vous devez impérativement mettre à jour manuellement le mot de passe du compte super admin unix dans la base de donnée farmserv avec la commande bash suivante :

echo "" >> /var/www/farmserv/mig_admin_pass_5.4.php && php -f /var/www/farmserv/mig_admin_pass_5.4.php > /dev/null && rm /var/www/farmserv/mig_admin_pass_5.4.php

Connectez-vous à partir d'un terminal sur votre serveur en tant que root (sudo su) et copier/coller entièrement cette (longue) commande en remplaçant PASSWORD_ADMIN_UNIX par le mot de passe du compte super admin unix. Si vous ne ne le faites pas, vous ne pourrez plus générer le fichier de configuration de votre instance !

Si votre instance comporte pas mal d'utilisateurs (plus de 10), il est fortement conseillé de modifier la variable php_value max_execution_time du fichier conf /etc/php/7.0/apache2/php.ini en métant la valeur à 300 (php_value max_execution_time 300) et de redémarrer apache2 (/etc/init.d/apache2 restart) avant de faire la mise à jour sinon la mise à jour ne se fera pas complètement pour la migration des mots de passe !

Kéran JACQUIN

Pas encore de commentaire

Ou